Changeset 1075 for packaging/qt.spec


Ignore:
Timestamp:
Sep 11, 2011, 7:57:24 PM (14 years ago)
Author:
Dmitry A. Kuminov
Message:

packaging: Fixed install script.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • packaging/qt.spec

    r1071 r1075  
    5959%if "%{?QT_SOURCE_TREE}" == ""
    6060%define QT_SOURCE_TREE .
    61 %endif
    62 
    63 %if "%{?QT_BUILD_TREE}" != ""
    64 %define skip_prep 1
    65 %define skip_build 1
    66 %define skip_install 1
    6761%endif
    6862
     
    8680%define qtM                 %{name}%{ver_major}
    8781
     82
     83
     84
    8885#------------------------------------------------------------------------------
    8986# main package
     
    337334%else
    338335# use passed source tree as is (shadow build)
    339 %setup -n "%{name}-%{version}" -TDc
     336%setup -n "%{name}-%{version}" -T
    340337%endif
    341338%else
     
    364361check_var "PSQL_INCLUDEPATH"
    365362check_var "PSQL_LIBS"
     363
     364
    366365
    367366# Qt links to some OS/2 DLLs directly (w/o import libs)
     
    391390
    392391# make sure the right DLLs are used by the build (and in particular by qdoc
    393 # in make install) in case if there is another Qt version installed
     392# in make ) in case if there is another Qt version installed
    394393export PATH="$BUILDDIR_D\\bin\;$PATH"
    395394export BEGINLIBPATH="$BUILDDIR_D\\bin\;$BEGINLIBPATH"
    396395
     396
     397
     398
     399
     400
    397401cmd /c $QT_SOURCE_TREE_D\\configure.cmd $library_paths
    398402
     403
     404
     405
     406
     407
     408
    399409# qdoc needs the qsqlite plugin but nothing is installed to target locations
    400410# yet, so generate qt.conf to override paths
     
    406416Demos = demos" \
    407417> "%{_builddir}/%{buildsubdir}/bin/qt.conf"
    408 
    409 make -j$MAKE_JOBS
    410 
    411 %if !0%{?skip_build_docs}
    412418make docs -j$MAKE_JOBS
     419
    413420%endif
    414421
     
    423430rm -rf %{buildroot}
    424431
    425 make install INSTALL_ROOT=%{buildroot}
     432# Qt links to some OS/2 DLLs directly (w/o import libs)
     433export LIBRARY_PATH=%{os2_boot_drive}/OS2/DLL\;%{os2_boot_drive}/MPTN/DLL\;$LIBRARY_PATH
     434
     435# CMD.EXE is required by the build process for now
     436export MAKESHELL=%{os2_boot_drive}\\OS2\\CMD.EXE
     437
     438# exclude install_htmldocs from install targets
     439make install_subtargets install_qchdocs install_qmake install_mkspecs \
     440    INSTALL_ROOT=$(echo "%{buildroot}/@unixroot" | sed -re 's,/,\\,g')
    426441
    427442# copy READMEs (make install doesn't do that)
    428 cp %{QT_SOURCE_TREE}/LICENSE.* \
    429    %{QT_SOURCE_TREE}/LGPL_EXCEPTION.txt \
    430    %{QT_SOURCE_TREE}/README \
    431    %{QT_SOURCE_TREE}/changes-%{ver_major}.%{ver_minor}.%{ver_} \
    432    %{QT_SOURCE_TREE}/README.OS2 \
    433    %{QT_SOURCE_TREE}/CHANGES.OS2 \
    434    %{pkg_docdir}/
     443mkdir -p %{buildroot}/%{pkg_docdir}/
     444cp -dp \
     445    %{QT_SOURCE_TREE}/LICENSE.* \
     446    %{QT_SOURCE_TREE}/LGPL_EXCEPTION.txt \
     447    %{QT_SOURCE_TREE}/README \
     448    %{QT_SOURCE_TREE}/changes-%{ver_major}.%{ver_minor}.%{ver_patch} \
     449    %{QT_SOURCE_TREE}/README.OS2 \
     450    %{QT_SOURCE_TREE}/CHANGES.OS2 \
     451    %{buildroot}/%{pkg_docdir}/
    435452
    436453%endif # if !0%{?skip_install}
Note: See TracChangeset for help on using the changeset viewer.